Micrium_Xilinx_Repo_1_44

Micrium_Xilinx_Repo_1_44

Home Forums Example Projects Micrium_Xilinx_Repo_1_44

This topic contains 2 replies, has 2 voices, and was last updated by  mike tran 1 week, 1 day ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #27081

    mike tran
    Participant

    Hi UCOS,

    vivado/sdk 2018.3, microzed 7z020, Micrium_Xilinx_Repo_1_44.zip

    I am trouble with latest Micrium_Xilinx_Repo_1_44.

    1. after adding repositories of ucos_v1_44 in SDK, I tried to construct a BSP project, however, there was no place to specify UART port (since my vivado block diagram contained both PS-UART0 and PS-UART1).

    previously ucos_v1_43 was able to select:

    system.mss –> modify this bsp’s settings –> configuration for OS: ucos –> 01. general_options –> STDIN_OUT –> ps7_uart_1

    2. then I tried Hello World program. Templates are empty, and message is “there is no supported application for selected processor and os”.

    follow https://forums.xilinx.com/t5/Embedded-Development-Tools/Question-about-ucos-templates/m-p/950419 , I am able to construct and compile the helloworld project in SDK. However, there are no uart outputs during debug on microzed board.

    Please advise, thanks in advance

    Mike

    #27085

    Hello Mike,

    The STDIO handling has been moved in 1.44.
    It is now located under ucos_standalone, to mimic the Xilinx standalone approach.

    Regards,
    Sharbel

    #27106

    mike tran
    Participant

    got it, thank you for the help.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

View the complete site map

x
Loading...