ucos for omap3

ucos for omap3

Home Forums Real-Time Kernels ucos for omap3

This topic contains 2 replies, has 2 voices, and was last updated by  ran shalit 2 years, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #18773

    ran shalit
    Participant

    Hello,

    I can’t find in download center selection for TI (texas instruments) OMAP3 chip.
    Other TI’s chip can be found but not omap3.

    Can you please give some start tips as to how to getting started with ucos for OMAP3 ?
    If there is some link for documentation on this it may help.
    Does ucos requires bootloader (like done with Linux) ?

    Thank you!
    Ran

    • This topic was modified 2 years, 11 months ago by  ran shalit.
    #18812

    Matt Gordon
    Keymaster

    Although Micrium doesn’t have any examples for hardware platforms based on the OMAP 3 family, the Download Center’s EVM-AM3517 project incorporates the Cortex-A8 port files that would be needed to run the µC/OS-II kernel on an OMAP 3 board. A kernel-based example project for such a board could be put together by combining the kernel’s code (including both the previously mentioned port and the hardware-independent kernel code found in the AM3517 example) with a simple BSP. Since µC/OS-II’s only peripheral requirement is for a periodic interrupt source, a BSP for a project incorporating the kernel often comprises just a handful of code, most of which can be taken from non-kernel-based examples.

    The BSP code required for µC/OS-II generally includes a few routines to set up interrupt hardware as well as startup code to initialize clocks and other essential hardware components before the application software begins running. Although a bootloader for µC/OS-II could have similar scope and capabilities to U-Boot, it’s possible to get by with much simpler boot code. In fact, many existing µC/OS-II and µC/OS-III examples utilize startup routines provided by the semiconductor manufacturers for bare-metal projects.

    #20765

    ran shalit
    Participant

    Hello,

    I am trying to use the example for AM3517.
    I see that AM3517 registers are identical to DM3730, as far as I checked, (for the interfaces used in the example)
    I use verscite’s var-som-om37 board:
    http://www.variscite.com/products/system-on-module-som/cortex-a8/var-som-om37-cpu-ti-am3703-dm3730

    But I have troubles showing a sign of life from uc/os with this baord:
    I don’t have jtag, so I try to load it from u-boot.
    I’ve build in IAR as-is from the web example (no issues or errors been encountered in the build).
    I then do in u-boot:
    I guess I should load it into 0x80000000 because I see in map file that the address to load __vector is 0x80000000 (Where is it being told to put it in 0x80000000, is it in icf file ?)

    So I did as following:

    u-boot> tftp 0x80000000 OS2.out
    u-boot> loadelf 0x80000000

    But nothing is displayed in terminal.
    I then tried to change main as following:

    int main (void)
    {
    while(1)
    {
    UART_tx_byte(UART1, 50 );
    UART_tx_byte(UART2, 50 );
    UART_tx_byte(UART3, 50 );
    }
    }
    I would assume that if nothing is
    Still, nothing is displayed in terminal.

    I then tried to change startup
    __iar_program_start:
    ?cstartup:
    ;;ranran
    B __cmain

    Thank you for any suggestion,
    Ran

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

View the complete site map

x
Loading...